Dll references not updating

27-Jul-2016 10:21

Even though this is not a Nuget bug and rather a problem caused by inexperience, I logged an issue with Nuget to see if they can improve the software to prevent these types of problems.Microsoft is conducting an online survey to understand your opinion of the Msdn Web site. We're a friendly computing community, bustling with knowledgeable members to help solve your tech questions.Please join our friendly community by clicking the button below - it only takes a few seconds and is totally free.It turns out, your .wdproj file may be out-of-sync with your . Double check the following XML elements inside your .wdproj file: It turns out, if you were using Visual Studio’s built-in Cassini web server, then switched to IIS Express at a later date, your .wdproj may contain stale reference information located in the two XML tags listed above.Specifically, the format of the tag using Cassini is “GUID|Project Path”, and “GUID|Project URL” for IIS Express.

dll references not updating-88dll references not updating-2dll references not updating-89dll references not updating-57

What was most strange about this problem was that all my builds worked before, so something must have goofed up the build process.It is working fine but problem is Data Logic Layer dll is not updating when i rebuild the Business Logic Application. 1) Project to Project reference in the same solution? You might try removing the reference and adding it back. It should be working the same in VS05 but VS05 is now based on MSBuild which is an entirely new project system.It's possible that there is a problem somewhere in the new system.For example, lets say I added a class called "Why Doesnt This Crap Work" in the new DLL. I open the new DLL in ILDASM and it has everything.I add the new dll to a new test application and it has everything. I have an application called "app" that references some of these dlls.

What was most strange about this problem was that all my builds worked before, so something must have goofed up the build process.

It is working fine but problem is Data Logic Layer dll is not updating when i rebuild the Business Logic Application. 1) Project to Project reference in the same solution? You might try removing the reference and adding it back. It should be working the same in VS05 but VS05 is now based on MSBuild which is an entirely new project system.

It's possible that there is a problem somewhere in the new system.

For example, lets say I added a class called "Why Doesnt This Crap Work" in the new DLL. I open the new DLL in ILDASM and it has everything.

I add the new dll to a new test application and it has everything. I have an application called "app" that references some of these dlls.

So where could my application be caching its reference to the old DLL, and what can I do to fix this and undo the reference? NET FAQ : ========================== "cmay" Maybe someone can give an idea of why I am having this problem before I put my fist through the computer screen. I make a change to one of the DLLs in the DLLS directory.